work on PRINT encoding
[pspp] / perl-module / Makefile.PL
index 56b8a930ce77ea4229cce6e6211bc9b27d58ac57..a315abbee2241363bd5c270e5af54297445e7d64 100644 (file)
@@ -19,10 +19,10 @@ WriteMakefile(
     PREREQ_PM         => {POSIX=>0}, 
     PM                => {"lib/PSPP.pm", "\$(INST_LIBDIR)/PSPP.pm"},
     ($] >= 5.005 ?     ## Add these new keywords supported since 5.005
-      (ABSTRACT_FROM  => 'lib/PSPP.pm', # retrieve abstract from module
+      (ABSTRACT       => 'Perl extension to PSPP',
        AUTHOR         => 'John Darrington <john@darrington.wattle.id.au>') : ()),
     INC       => "-I $Locations{SourceDir}  -I $Locations{SourceDir}/src -I $Locations{SourceDir}/gl -I $Locations{BuildDir}/gl -I $Locations{BuildDir}", 
-    MYEXTLIB  => "$Locations{BuildDir}/src/.libs/libpspp-core.\$(DLEXT)",
+    MYEXTLIB  => "$Locations{BuildDir}/src/.libs/libpspp-core.\$(SO)",
     MAN3PODS  => {"lib/PSPP.pm", "\$(INST_MAN3DIR)/PSPP.3pm",
            "Examples.pod", "\$(INST_MAN3DIR)/PSPP::Examples.3pm"}
 );