Adopt use of gnulib for portability.
[pspp-builds.git] / src / Makefile.am
index 6623c2540060401cd9ba17e3cf98fc2d99d4c2c4..dcb6d078f511c49976a084f0dd12020da18fc713 100644 (file)
@@ -44,7 +44,6 @@ endif
 pspp_SOURCES = $(q_sources_c) $(chart_sources) \
 aggregate.c algorithm.c algorithm.h    \
 alloc.c alloc.h apply-dict.c ascii.c autorecode.c bitvector.h          \
-bool.h \
 calendar.c calendar.h case.c case.h casefile.c casefile.h chart.c      \
 chart.h cmdline.c cmdline.h command.c command.def \
 command.h compute.c copyleft.c copyleft.h count.c data-in.c data-in.h  \
@@ -53,7 +52,7 @@ devind.c devind.h dfm-read.c dfm-read.h dfm-write.c dfm-write.h       \
 dictionary.c dictionary.h do-if.c do-ifP.h echo.c error.c \
 error.h factor_stats.c factor_stats.h file-handle.h    \
 file-type.c filename.c filename.h flip.c font.h format.c format.def    \
-format.h formats.c get.c getline.c getline.h glob.c glob.h             \
+format.h formats.c get.c getl.c getl.h glob.c glob.h           \
 groff-font.c group.c group.h group_proc.h \
 hash.c hash.h histogram.c histogram.h \
 html.c htmlP.h include.c inpt-pgm.c lexer.c lexer.h levene.c levene.h \
@@ -68,17 +67,17 @@ rename-vars.c repeat.c repeat.h sample.c sel-if.c settings.h                \
 sfm-read.c sfm-read.h sfm-write.c sfm-write.h sfmP.h som.c som.h       \
 sort.c sort.h sort-prs.c sort-prs.h \
 split-file.c str.c str.h subclist.c subclist.h \
-sysfile-info.c tab.c tab.h temporary.c stat.h mkfile.c mkfile.h \
+sysfile-info.c tab.c tab.h temporary.c mkfile.c mkfile.h \
 title.c  val.h val-labs.c value-labels.c value-labels.h                \
 var-display.c \
 var-labs.c var.h vars-atr.c vars-prs.c vector.c version.h      \
 vfm.c vfm.h vfmP.h weight.c 
 
 
-pspp_LDADD = \
-       ../lib/misc/libmisc.a                   \
+pspp_LDADD =                                   \
        expressions/libexpressions.a            \
        ../lib/gsl-extras/libgsl-extras.a       \
+       ../gl/libgl.a                           \
        @LIBINTL@
 
 nodist_pspp_SOURCES = version.c