Sat Dec 27 16:16:49 2003 Ben Pfaff <blp@gnu.org>
[pspp-builds.git] / src / Makefile.am
index 2957ac492d865085e2185e9200fc3535ccb6147b..906f25cd1e02b770a6f5236f5151c9916810dabd 100644 (file)
@@ -29,23 +29,24 @@ frequencies.q list.q means.q set.q t-test.q
 
 pspp_SOURCES = aggregate.c algorithm.c algorithm.h alloc.c alloc.h     \
 apply-dict.c approx.h ascii.c autorecode.c bitvector.h cases.c cases.h \
-cmdline.c command.c command.def command.h compute.c correlations.c     \
-count.c crosstabs.c data-in.c data-in.h data-list.c data-out.c         \
-debug-print.h descript.c dfm.c dfm.h do-if.c do-ifP.h error.c error.h  \
-expr-evl.c expr-opt.c expr-prs.c expr.h exprP.h file-handle.c          \
-file-handle.h file-type.c filename.c filename.h flip.c font.h format.c \
-format.def format.h formats.c frequencies.c get.c getline.c getline.h  \
-glob.c groff-font.c hash.c hash.h heap.c heap.h html.c htmlP.h         \
-include.c inpt-pgm.c inpt-pgm.h lexer.c lexer.h list.c log.h loop.c    \
-magic.c magic.h main.c main.h matrix-data.c matrix.c matrix.h means.c  \
-mis-val.c misc.c misc.h modify-vars.c numeric.c output.c output.h      \
-pfm-read.c pfm-write.c pfm.h pool.c pool.h postscript.c print.c                \
-random.c random.h recode.c rename-vars.c repeat.c sample.c sel-if.c    \
-set.c settings.h sfm-read.c sfm-write.c sfm.h sfmP.h som.c som.h       \
-sort.c sort.h split-file.c stat.h stats.c stats.h str.c str.h          \
-sysfile-info.c tab.c tab.h temporary.c title.c t-test.c val-labs.c     \
-value-labels.c value-labels.h var-labs.c var.h vars-atr.c vars-prs.c   \
-vector.c vector.h version.c version.h vfm.c vfm.h vfmP.h weight.c
+cmdline.c cmdline.h command.c command.def command.h compute.c          \
+correlations.c count.c crosstabs.c data-in.c data-in.h data-list.c     \
+data-out.c debug-print.h descript.c dfm.c dfm.h dictionary.c do-if.c   \
+do-ifP.h error.c error.h expr-evl.c expr-opt.c expr-prs.c expr.h       \
+exprP.h file-handle.c file-handle.h file-type.c filename.c filename.h  \
+flip.c font.h format.c format.def format.h formats.c frequencies.c     \
+get.c getline.c getline.h glob.c glob.h groff-font.c hash.c hash.h     \
+heap.c heap.h html.c htmlP.h include.c inpt-pgm.c lexer.c lexer.h      \
+list.c log.h loop.c magic.c magic.h main.c main.h matrix-data.c                \
+matrix.c matrix.h means.c mis-val.c misc.c misc.h modify-vars.c                \
+numeric.c output.c output.h pfm-read.c pfm-write.c pfm.h pool.c pool.h \
+postscript.c print.c random.c random.h recode.c rename-vars.c repeat.c \
+repeat.h sample.c sel-if.c set.c settings.h sfm-read.c sfm-write.c     \
+sfm.h sfmP.h som.c som.h sort.c sort.h split-file.c stat.h stats.c     \
+stats.h str.c str.h sysfile-info.c tab.c tab.h temporary.c title.c     \
+t-test.c val-labs.c value-labels.c value-labels.h var-labs.c var.h     \
+vars-atr.c vars-prs.c vector.c version.c version.h vfm.c vfm.h vfmP.h  \
+weight.c
 
 pspp_LDADD =   ../lib/julcal/libjulcal.a               \
        ../lib/misc/libmisc.a                   \
@@ -54,6 +55,7 @@ pspp_LDADD =  ../lib/julcal/libjulcal.a               \
 
 version.c:
        echo "#include <config.h>" > version.c
+       echo "#include \"version.h\"" > version.c
        echo "const char bare_version[] = \"@VERSION@\";" >> version.c
        echo "const char version[] = \"GNU @PACKAGE@ @VERSION@\";" >> version.c
        echo "const char stat_version[] = \"GNU @PACKAGE@ @VERSION@ \