Link the perl module against the shared library instead of the static one
[pspp-builds.git] / perl-module / Makefile.PL
index 20587a62fe575c54f1da8d752901c727a7c9a64d..cf4131760c0e875a771b3053d7f42f538db944e6 100644 (file)
@@ -22,7 +22,7 @@ WriteMakefile(
       (ABSTRACT_FROM  => 'lib/PSPP.pm', # retrieve abstract from module
        AUTHOR         => 'John Darrington <john@darrington.wattle.id.au>') : ()),
     INC       => "-I $Locations{SourceDir}  -I $Locations{SourceDir}/src -I $Locations{SourceDir}/gl -I $Locations{BuildDir}/gl -I $Locations{BuildDir}", 
-    MYEXTLIB  => "$Locations{BuildDir}/src/.libs/libpspp-core\$(LIB_EXT)",
+    MYEXTLIB  => "$Locations{BuildDir}/src/.libs/libpspp-core.\$(DLEXT)",
     MAN3PODS  => {"lib/PSPP.pm", "\$(INST_MAN3DIR)/PSPP.3pm",
            "Examples.pod", "\$(INST_MAN3DIR)/PSPP::Examples.3pm"}
 );