Automatically detect src dir from build dir
[pspp-builds.git] / perl-module / Makefile.PL
index dfa235e76562f07a31d7f2053cdb9aaf590f010f..77505f2f27ecaa5e4b5f14a1afdecb6938611992 100644 (file)
@@ -5,8 +5,9 @@ use ExtUtils::MakeMaker;
 
 
 do 'pspp-module-config' || do {
-    my $src = prompt ("Enter the location of the full pspp source","../pspp");
-    my $build = prompt ("Enter the location of the pspp build directory", "$src" );
+    my $build = prompt ("Enter the location of the build directory of the configured pspp source:", "" );
+    do 'lib/pspp-vers.pl' || die "No version info";
+    my $src = $top_srcdir;
 
     %Locations = (SourceDir => "$src", BuildDir => "$build");
 };