Fix missing @clicksequence problem with older Texinfo versions.
[pspp-builds.git] / perl-module / Makefile.PL
index dfa235e76562f07a31d7f2053cdb9aaf590f010f..045b4e767710e0ba7b2d43b21c03c0a07316cb6b 100644 (file)
@@ -5,23 +5,24 @@ use ExtUtils::MakeMaker;
 
 
 do 'pspp-module-config' || do {
-    my $src = prompt ("Enter the location of the full pspp source","../pspp");
-    my $build = prompt ("Enter the location of the pspp build directory", "$src" );
+    my $build = prompt ("Enter the location of the build directory of the configured pspp source:", "" );
+    my $src = $top_srcdir;
 
     %Locations = (SourceDir => "$src", BuildDir => "$build");
 };
 
 WriteMakefile(
+    FULLPERL          => "PSPP_TEST_CMD=\"$Locations{BuildDir}/src/ui/terminal/pspp -B $Locations{SourceDir}/config\" \$(PERL)",
     NAME              => 'PSPP',
     DISTNAME          => 'PSPP-Perl',
     VERSION_FROM      => "$Locations{BuildDir}/src/libpspp/version.c", 
     PREREQ_PM         => {POSIX=>0}, 
+    PM                => {"lib/PSPP.pm", "\$(INST_LIBDIR)/PSPP.pm"},
     ($] >= 5.005 ?     ## Add these new keywords supported since 5.005
       (ABSTRACT_FROM  => 'lib/PSPP.pm', # retrieve abstract from module
        AUTHOR         => 'John Darrington <john@darrington.wattle.id.au>') : ()),
     INC       => "-I $Locations{SourceDir}  -I $Locations{SourceDir}/src -I $Locations{SourceDir}/gl -I $Locations{BuildDir}/gl -I $Locations{BuildDir}", 
-
-    MYEXTLIB  => "$Locations{BuildDir}/src/.libs/libpspp-core\$(LIB_EXT)",
+    MYEXTLIB  => "$Locations{BuildDir}/src/.libs/libpspp-core.\$(DLEXT)",
     MAN3PODS  => {"lib/PSPP.pm", "\$(INST_MAN3DIR)/PSPP.3pm",
            "Examples.pod", "\$(INST_MAN3DIR)/PSPP::Examples.3pm"}
 );