Fix missing @clicksequence problem with older Texinfo versions.
[pspp-builds.git] / perl-module / Makefile.PL
index cf4131760c0e875a771b3053d7f42f538db944e6..045b4e767710e0ba7b2d43b21c03c0a07316cb6b 100644 (file)
@@ -6,7 +6,6 @@ use ExtUtils::MakeMaker;
 
 do 'pspp-module-config' || do {
     my $build = prompt ("Enter the location of the build directory of the configured pspp source:", "" );
-    do 'lib/pspp-vers.pl' || die "No version info";
     my $src = $top_srcdir;
 
     %Locations = (SourceDir => "$src", BuildDir => "$build");
@@ -18,6 +17,7 @@ WriteMakefile(
     DISTNAME          => 'PSPP-Perl',
     VERSION_FROM      => "$Locations{BuildDir}/src/libpspp/version.c", 
     PREREQ_PM         => {POSIX=>0}, 
+    PM                => {"lib/PSPP.pm", "\$(INST_LIBDIR)/PSPP.pm"},
     ($] >= 5.005 ?     ## Add these new keywords supported since 5.005
       (ABSTRACT_FROM  => 'lib/PSPP.pm', # retrieve abstract from module
        AUTHOR         => 'John Darrington <john@darrington.wattle.id.au>') : ()),