debian: Ignore directories created as part of Debian package build.
[openvswitch] / xenserver / vswitch-xen.spec
index 58e35dec95e6b8cc23f5bb8e78dece0d6d8b8933..a9933d9b3664aedc6182969e6151e332ba9039be 100644 (file)
@@ -25,6 +25,7 @@ License: GPL3
 Release: 1
 Source: openvswitch-%{vswitch_version}.tar.gz
 Buildroot: /tmp/vswitch-xen-rpm
+Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
 
 %description
 The vswitch provides standard network bridging functions augmented with
@@ -114,7 +115,7 @@ EOF
     fi
 fi
 
-if test ! -e /etc/vswitch.dbcache; then
+if test ! -e /etc/ovs-vswitch.dbcache; then
     if test "$1" = 1; then
         printf "Creating xapi database cache...  "
     else
@@ -141,7 +142,7 @@ try:
 finally:
     session.xenapi.session.logout()
 
-dbcache_file = "/etc/vswitch.dbcache"
+dbcache_file = "/etc/ovs-vswitch.dbcache"
 f = open(dbcache_file, 'w')
 pickle.dump({'vlans': vlans,
              'bonds': bonds,