ovs-controller: Add ability to define default flows
[openvswitch] / debian / automake.mk
index 1b649453f6dc7d8f53fd40b96549eb99a12434be..7c656c8a8d284a12bd33881ba3b42ca079e40d6b 100644 (file)
@@ -61,3 +61,14 @@ EXTRA_DIST += \
        debian/reconfigure \
        debian/rules \
        debian/rules.modules
+
+check-debian-changelog-version:
+       @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
+       then                                                               \
+         :;                                                               \
+       else                                                               \
+         echo "Update debian/changelog to mention version $(VERSION)";    \
+         exit 1;                                                          \
+       fi
+ALL_LOCAL += check-debian-changelog-version
+DIST_HOOKS += check-debian-changelog-version