tests: Fix the two Python XFAIL tests.
[openvswitch] / debian / automake.mk
index f493100148e8d85c0a7a0aea518a348835869dae..5fac4c85e19292247df314c4f07694ee5416df58 100644 (file)
@@ -34,6 +34,8 @@ EXTRA_DIST += \
        debian/openvswitch-switch.postinst \
        debian/openvswitch-switch.postrm \
        debian/openvswitch-switch.template \
+       debian/ovsdbmonitor.install \
+       debian/ovsdbmonitor.manpages \
        debian/ovs-bugtool \
        debian/ovs-bugtool.8 \
        debian/ovs-monitor-ipsec \
@@ -43,12 +45,13 @@ EXTRA_DIST += \
        debian/rules.modules
 
 check-debian-changelog-version:
-       @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
-       then                                                               \
-         :;                                                               \
-       else                                                               \
-         echo "Update debian/changelog to mention version $(VERSION)";    \
-         exit 1;                                                          \
+       @DEB_VERSION=`echo '$(VERSION)' | sed 's/pre/~pre/'`;                \
+       if $(FGREP) '($(DEB_VERSION)' $(srcdir)/debian/changelog >/dev/null; \
+       then                                                                 \
+         :;                                                                 \
+       else                                                                 \
+         echo "Update debian/changelog to mention version $(VERSION)";      \
+         exit 1;                                                            \
        fi
 ALL_LOCAL += check-debian-changelog-version
 DIST_HOOKS += check-debian-changelog-version