1 # Spec file for vswitch and related programs.
3 # Copyright (C) 2009 Nicira Networks, Inc.
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved. This file is offered as-is,
8 # without warranty of any kind.
10 # When building, the rpmbuild command line should define
11 # vswitch_version, xen_version, and build_number using -D arguments.
14 # rpmbuild -D "vswitch_version 0.8.9~1+build123" -D "xen_version 2.6.18-128.1.1.el5.xs5.1.0.483.1000xen" -D "build_number --with-build-number=123" -bb /usr/src/redhat/SPECS/vswitch-xen.spec
16 %define version %{vswitch_version}-%{xen_version}
17 %define _prefix /root/vswitch
20 Summary: Virtual switch
21 Group: System Environment/Daemons
22 URL: http://www.openvswitch.org/
23 Version: %{vswitch_version}
25 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
26 License: ASL 2.0 and GPLv2
28 Source: openvswitch-%{vswitch_version}.tar.gz
29 Buildroot: /tmp/vswitch-xen-rpm
30 Requires: kernel-xen = %(echo '%{xen_version}' | sed 's/xen$//')
33 The vswitch provides standard network bridging functions augmented with
34 support for the OpenFlow protocol for remote per-flow control of
38 %setup -q -n openvswitch-%{vswitch_version}
41 ./configure --prefix=%{_prefix} --localstatedir=%{_localstatedir} --with-l26=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
45 rm -rf $RPM_BUILD_ROOT
46 make install DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix}
47 install -d -m 755 $RPM_BUILD_ROOT/etc
48 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
49 install -m 755 xenserver/etc_init.d_vswitch \
50 $RPM_BUILD_ROOT/etc/init.d/vswitch
51 install -m 755 xenserver/etc_init.d_vswitch-xapi-update \
52 $RPM_BUILD_ROOT/etc/init.d/vswitch-xapi-update
53 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
54 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
55 install -m 755 xenserver/etc_logrotate.d_vswitch \
56 $RPM_BUILD_ROOT/etc/logrotate.d/vswitch
57 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
58 install -m 755 xenserver/etc_profile.d_vswitch.sh \
59 $RPM_BUILD_ROOT/etc/profile.d/vswitch.sh
60 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
61 install -m 755 xenserver/etc_xapi.d_plugins_vswitch-cfg-update \
62 $RPM_BUILD_ROOT/etc/xapi.d/plugins/vswitch-cfg-update
63 install -d -m 755 $RPM_BUILD_ROOT%{_prefix}/scripts
64 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
65 $RPM_BUILD_ROOT%{_prefix}/scripts/interface-reconfigure
66 install -m 755 xenserver/etc_xensource_scripts_vif \
67 $RPM_BUILD_ROOT%{_prefix}/scripts/vif
68 install -m 755 xenserver/root_vswitch_scripts_dump-vif-details \
69 $RPM_BUILD_ROOT%{_prefix}/scripts/dump-vif-details
70 install -m 755 xenserver/usr_sbin_xen-bugtool \
71 $RPM_BUILD_ROOT%{_prefix}/scripts/xen-bugtool
72 install -m 755 xenserver/usr_sbin_brctl \
73 $RPM_BUILD_ROOT%{_prefix}/scripts/brctl
74 install -m 755 xenserver/root_vswitch_scripts_sysconfig.template \
75 $RPM_BUILD_ROOT/root/vswitch/scripts/sysconfig.template
77 xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
78 $RPM_BUILD_ROOT%{_prefix}/scripts/XSFeatureVSwitch.py
80 install -d -m 755 $RPM_BUILD_ROOT%{_prefix}/kernel_modules
81 find datapath/linux-2.6 -name *.ko -exec install -m 755 \{\} $RPM_BUILD_ROOT%{_prefix}/kernel_modules/ \;
83 # Get rid of stuff we don't want to make RPM happy.
85 $RPM_BUILD_ROOT/root/vswitch/bin/ezio-term \
86 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-controller \
87 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-discover \
88 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-kill \
89 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-openflowd \
90 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-pki \
91 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-switchui \
92 $RPM_BUILD_ROOT/root/vswitch/bin/ovs-wdt \
93 $RPM_BUILD_ROOT/root/vswitch/kernel_modules/veth_mod.ko \
94 $RPM_BUILD_ROOT/root/vswitch/sbin/ovs-monitor \
95 $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-controller.8 \
96 $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-discover.8 \
97 $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-kill.8 \
98 $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-openflowd.8 \
99 $RPM_BUILD_ROOT/root/vswitch/share/man/man8/ovs-pki.8 \
100 $RPM_BUILD_ROOT/root/vswitch/share/openvswitch
103 rm -rf $RPM_BUILD_ROOT
106 if [ ! -f /etc/xensource-inventory ]; then
107 printf "XenSource inventory not present in /etc/xensource-inventory"
111 if [ "$1" = "1" ]; then
112 if ! md5sum -c --status <<EOF
113 b8e9835862ef1a9cec2a3f477d26c989 /etc/xensource/scripts/vif
114 51970ad613a3996d5997e18e44db47da /opt/xensource/libexec/interface-reconfigure
115 5654c8c36699fcc8744ca9cd5b855414 /usr/sbin/xen-bugtool
118 printf "\nThe original XenServer scripts replaced by this package\n"
119 printf "are different than expected. This could lead to unexpected\n"
120 printf "behavior of your server. Unless you are sure you know what\n"
121 printf "you are doing, it is highly recommended that you remove this\n"
122 printf "package immediately after the install completes, which\n"
123 printf "will restore the XenServer scripts that you were previously\n"
126 if test "`/usr/sbin/brctl --version`" != "bridge-utils, 1.1"; then
129 /usr/sbin/brctl replaced by this package reports the following version:
131 `/usr/sbin/brctl --version`
133 The expected version was:
137 Unless you are sure you know what you are doing, it is highly recommended that
138 you remove this package immediately after the install completes, which will
139 restore the original /usr/sbin/brctl.
145 if test ! -e /etc/ovs-vswitch.dbcache; then
146 if test "$1" = 1; then
147 printf "Creating xapi database cache... "
149 printf "warning: Open vSwitch is being re-installed or upgraded,\n"
150 printf " but the xapi database cache is missing.\n"
151 printf "Re-creating xapi database cache... "
154 source /etc/xensource-inventory
155 if python - "$INSTALLATION_UUID" <<EOF
160 session = XenAPI.xapi_local()
162 session.xenapi.login_with_password("root", "")
164 vlans = session.xenapi.VLAN.get_all_records()
165 bonds = session.xenapi.Bond.get_all_records()
166 pifs = session.xenapi.PIF.get_all_records()
167 networks = session.xenapi.network.get_all_records()
168 host = session.xenapi.host.get_by_uuid(sys.argv[1])
170 session.xenapi.session.logout()
172 dbcache_file = "/etc/ovs-vswitch.dbcache"
173 f = open(dbcache_file, 'w')
174 pickle.dump({'vlans': vlans,
177 'networks': networks}, f)
178 pickle.dump({'host': host}, f)
185 printf "Open vSwitch can only be installed on a XenServer that\n"
186 printf "has connectivity to xapi on the pool master. Please\n"
187 printf "fix connectivity to the pool master, then try again.\n"
193 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
194 cat >>/etc/sysctl.conf <<EOF
195 # This works around an issue in xhad, which binds to a particular
196 # Ethernet device, which in turn causes ICMP port unreachable messages
197 # if packets are received are on the wrong interface, which in turn
198 # can happen if we send out ARP replies on every interface (as Linux
199 # does by default) instead of just on the interface that has the IP
200 # address being ARPed for, which this sysctl setting in turn works
204 net.ipv4.conf.all.arp_filter = 1
208 # Ensure ovs-vswitchd.conf exists
209 touch /etc/ovs-vswitchd.conf
211 # Create default or update existing /etc/sysconfig/vswitch.
212 SYSCONFIG=/etc/sysconfig/vswitch
213 TEMPLATE=/root/vswitch/scripts/sysconfig.template
214 if [ ! -e $SYSCONFIG ]; then
215 cp $TEMPLATE $SYSCONFIG
217 for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
219 if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
221 sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
226 # Replace XenServer files by our versions.
227 mkdir -p %{_prefix}/xs-original \
228 || printf "Could not create script backup directory.\n"
230 /opt/xensource/libexec/interface-reconfigure \
231 /etc/xensource/scripts/vif \
232 /usr/sbin/xen-bugtool \
237 if [ "$t" != "%{_prefix}/scripts/$s" ]; then
238 mv "$f" %{_prefix}/xs-original/ \
239 || printf "Could not save original XenServer $s script\n"
240 ln -s "%{_prefix}/scripts/$s" "$f" \
241 || printf "Could not link to vSwitch $s script\n"
245 # Install xsconsole plugin
246 plugin=$(readlink /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py)
247 if [ "$plugin" != "/root/vswitch/scripts/XSFeatureVSwitch.py" ]; then
248 rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
249 ln -s /root/vswitch/scripts/XSFeatureVSwitch.py /usr/lib/xsconsole/plugins-base/ || printf "Could not link to vSswitch xsconsole plugin.\n"
252 # Ensure all required services are set to run
253 for s in vswitch vswitch-xapi-update; do
254 if chkconfig --list $s >/dev/null 2>&1; then
255 chkconfig --del $s || printf "Could not remove $s init script."
257 chkconfig --add $s || printf "Could not add $s init script."
258 chkconfig $s on || printf "Could not enable $s init script."
261 if [ "$1" = "1" ]; then # $1 = 2 for upgrade
262 printf "\nYou MUST reboot the server NOW to complete the change to the\n"
263 printf "the vSwitch. Attempts to modify networking on the server\n"
264 printf "or any hosted VM will fail until after the reboot and could\n"
265 printf "leave the server in an state requiring manual recovery.\n\n"
267 printf "\nTo use the new vSwitch, you should reboot the server\n"
268 printf "now. Failure to do so may result in incorrect operation.\n\n"
272 if [ "$1" = "0" ]; then # $1 = 1 for upgrade
273 for s in vswitch vswitch-xapi-update; do
274 chkconfig --del $s || printf "Could not remove $s init script."
280 if [ "$1" = "0" ]; then # $1 = 1 for upgrade
282 rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py \
283 /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
284 /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo \
285 || printf "Could not remove vSwitch xsconsole plugin.\n"
287 # Restore original XenServer scripts
289 /opt/xensource/libexec/interface-reconfigure \
290 /etc/xensource/scripts/vif \
291 /usr/sbin/xen-bugtool \
295 if [ ! -f "%{_prefix}/xs-original/$s" ]; then
296 printf "Original XenServer $s script not present in %{_prefix}/xs-original\n"
297 printf "Could not restore original XenServer script.\n"
300 && mv "%{_prefix}/xs-original/$s" "$f") \
301 || printf "Could not restore original XenServer $s script.\n"
305 find %{_prefix} -type d -depth -exec rmdir \{\} \; \
306 || printf "Could not remove vSwitch install directory.\n"
308 # Remove all configuration and log files
309 rm -f /etc/ovs-vswitchd.conf
310 rm -f /etc/sysconfig/vswitch
311 rm -f /var/log/vswitch*
312 rm -f /etc/ovs-vswitchd.cacert
314 printf "\nYou MUST reboot the server now to complete the change to\n"
315 printf "standard Xen networking. Attempts to modify networking on the\n"
316 printf "server or any hosted VM will fail until after the reboot and\n"
317 printf "could leave the server in a state requiring manual recovery.\n\n"
322 %defattr(-,root,root)
324 /etc/init.d/vswitch-xapi-update
325 /etc/xapi.d/plugins/vswitch-cfg-update
326 /etc/logrotate.d/vswitch
327 /etc/profile.d/vswitch.sh
328 /root/vswitch/kernel_modules/brcompat_mod.ko
329 /root/vswitch/kernel_modules/openvswitch_mod.ko
330 /root/vswitch/scripts/dump-vif-details
331 /root/vswitch/scripts/interface-reconfigure
332 /root/vswitch/scripts/vif
333 /root/vswitch/scripts/xen-bugtool
334 /root/vswitch/scripts/XSFeatureVSwitch.py
335 /root/vswitch/scripts/brctl
336 /root/vswitch/scripts/sysconfig.template
337 # Following two files are generated automatically by rpm. We don't
338 # really need them and they won't be used on the XenServer, but there
339 # isn't an obvious place to get rid of them since they are generated
340 # after the install script runs. Since they are small, we just
342 /root/vswitch/scripts/XSFeatureVSwitch.pyc
343 /root/vswitch/scripts/XSFeatureVSwitch.pyo
344 /root/vswitch/sbin/ovs-brcompatd
345 /root/vswitch/sbin/ovs-vswitchd
346 /root/vswitch/bin/ovs-appctl
347 /root/vswitch/bin/ovs-cfg-mod
348 /root/vswitch/bin/ovs-dpctl
349 /root/vswitch/bin/ovs-ofctl
350 /root/vswitch/share/man/man5/ovs-vswitchd.conf.5
351 /root/vswitch/share/man/man8/ovs-appctl.8
352 /root/vswitch/share/man/man8/ovs-brcompatd.8
353 /root/vswitch/share/man/man8/ovs-cfg-mod.8
354 /root/vswitch/share/man/man8/ovs-dpctl.8
355 /root/vswitch/share/man/man8/ovs-ofctl.8
356 /root/vswitch/share/man/man8/ovs-vswitchd.8