1 # Spec file for Open vSwitch.
3 # Copyright (C) 2009, 2010, 2011 Nicira Networks, Inc.
5 # Copying and distribution of this file, with or without modification,
6 # are permitted in any medium without royalty provided the copyright
7 # notice and this notice are preserved. This file is offered as-is,
8 # without warranty of any kind.
10 # When building, the rpmbuild command line should define
11 # openvswitch_version, kernel_name, kernel_version, kernel_flavor,
12 # and build_number using -D arguments.
15 # rpmbuild -D "openvswitch_version 1.1.0+build123"
16 # -D "kernel_name NAME-xen"
17 # -D "kernel_version 2.6.32.12-0.7.1.xs5.6.100.323.170596"
18 # -D "kernel_flavor xen"
19 # -D "build_number --with-build-number=123"
20 # -bb /usr/src/redhat/SPECS/openvswitch-xen.spec
22 %define xen_version %{kernel_version}%{kernel_flavor}
24 # bump this when breaking compatibility with userspace
25 %define module_abi_version 0
27 # build-supplemental-pack.sh requires this naming for kernel module packages
28 %define module_package modules-%{kernel_flavor}-%{kernel_version}
31 Summary: Open vSwitch daemon/database/utilities
32 Group: System Environment/Daemons
33 URL: http://www.openvswitch.org/
34 Vendor: Nicira Networks, Inc.
35 Version: %{openvswitch_version}
39 Source: openvswitch-%{openvswitch_version}.tar.gz
40 Buildroot: /tmp/openvswitch-xen-rpm
41 Requires: openvswitch_mod.ko.%{module_abi_version}
44 Open vSwitch provides standard network bridging functions augmented with
45 support for the OpenFlow protocol for remote per-flow control of
48 %package %{module_package}
49 Summary: Open vSwitch kernel module
50 Group: System Environment/Kernel
52 Provides: %{name}-modules-%{kernel_flavor} = %{kernel_version}, openvswitch_mod.ko.%{module_abi_version}
53 Requires: kernel-%{kernel_name} = %{kernel_version}
55 %description %{module_package}
56 Open vSwitch Linux kernel module compiled against kernel version
60 %setup -q -n openvswitch-%{openvswitch_version}
63 ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=%{_localstatedir} --with-linux=/lib/modules/%{xen_version}/build --enable-ssl %{build_number}
67 rm -rf $RPM_BUILD_ROOT
68 make install DESTDIR=$RPM_BUILD_ROOT
69 install -d -m 755 $RPM_BUILD_ROOT/etc
70 install -d -m 755 $RPM_BUILD_ROOT/etc/init.d
71 install -m 755 xenserver/etc_init.d_openvswitch \
72 $RPM_BUILD_ROOT/etc/init.d/openvswitch
73 install -m 755 xenserver/etc_init.d_openvswitch-xapi-update \
74 $RPM_BUILD_ROOT/etc/init.d/openvswitch-xapi-update
75 install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
76 install -d -m 755 $RPM_BUILD_ROOT/etc/logrotate.d
77 install -m 755 xenserver/etc_logrotate.d_openvswitch \
78 $RPM_BUILD_ROOT/etc/logrotate.d/openvswitch
79 install -d -m 755 $RPM_BUILD_ROOT/etc/profile.d
80 install -m 755 xenserver/etc_profile.d_openvswitch.sh \
81 $RPM_BUILD_ROOT/etc/profile.d/openvswitch.sh
82 install -d -m 755 $RPM_BUILD_ROOT/etc/xapi.d/plugins
83 install -m 755 xenserver/etc_xapi.d_plugins_openvswitch-cfg-update \
84 $RPM_BUILD_ROOT/etc/xapi.d/plugins/openvswitch-cfg-update
85 install -d -m 755 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts
86 install -m 755 xenserver/opt_xensource_libexec_interface-reconfigure \
87 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/interface-reconfigure
88 install -m 644 xenserver/opt_xensource_libexec_InterfaceReconfigure.py \
89 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/InterfaceReconfigure.py
90 install -m 644 xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py \
91 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/InterfaceReconfigureBridge.py
92 install -m 644 xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py \
93 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/InterfaceReconfigureVswitch.py
94 install -m 755 xenserver/etc_xensource_scripts_vif \
95 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/vif
96 install -m 755 xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync \
97 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/ovs-xapi-sync
98 install -m 755 xenserver/usr_share_openvswitch_scripts_sysconfig.template \
99 $RPM_BUILD_ROOT/usr/share/openvswitch/scripts/sysconfig.template
100 install -d -m 755 $RPM_BUILD_ROOT/usr/lib/xsconsole/plugins-base
102 xenserver/usr_lib_xsconsole_plugins-base_XSFeatureVSwitch.py \
103 $RPM_BUILD_ROOT/usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
105 install -d -m 755 $RPM_BUILD_ROOT/lib/modules/%{xen_version}/extra/openvswitch
106 find datapath/linux -name *.ko -exec install -m 755 \{\} $RPM_BUILD_ROOT/lib/modules/%{xen_version}/extra/openvswitch \;
107 install python/compat/uuid.py $RPM_BUILD_ROOT/usr/share/openvswitch/python
108 install python/compat/argparse.py $RPM_BUILD_ROOT/usr/share/openvswitch/python
110 install -d -m 755 $RPM_BUILD_ROOT/etc/xensource/bugtool
111 mv $RPM_BUILD_ROOT/etc/openvswitch/bugtool-plugins/* $RPM_BUILD_ROOT/etc/xensource/bugtool
113 # Get rid of stuff we don't want to make RPM happy.
115 $RPM_BUILD_ROOT/usr/bin/ovs-benchmark \
116 $RPM_BUILD_ROOT/usr/sbin/ovs-bugtool \
117 $RPM_BUILD_ROOT/usr/bin/ovs-controller \
118 $RPM_BUILD_ROOT/usr/bin/ovs-pki \
119 $RPM_BUILD_ROOT/usr/share/man/man1/ovs-benchmark.1 \
120 $RPM_BUILD_ROOT/usr/share/man/man8/ovs-bugtool.8 \
121 $RPM_BUILD_ROOT/usr/share/man/man8/ovs-controller.8 \
122 $RPM_BUILD_ROOT/usr/share/man/man8/ovs-pki.8
124 install -d -m 755 $RPM_BUILD_ROOT/var/lib/openvswitch
127 rm -rf $RPM_BUILD_ROOT
130 if grep -F net.ipv4.conf.all.arp_filter /etc/sysctl.conf >/dev/null 2>&1; then :; else
131 cat >>/etc/sysctl.conf <<EOF
132 # This works around an issue in xhad, which binds to a particular
133 # Ethernet device, which in turn causes ICMP port unreachable messages
134 # if packets are received are on the wrong interface, which in turn
135 # can happen if we send out ARP replies on every interface (as Linux
136 # does by default) instead of just on the interface that has the IP
137 # address being ARPed for, which this sysctl setting in turn works
141 net.ipv4.conf.all.arp_filter = 1
145 if test ! -e /etc/openvswitch/conf.db; then
146 install -d -m 755 -o root -g root /etc/openvswitch
148 # Create ovs-vswitchd config database
149 ovsdb-tool -vANY:console:off create /etc/openvswitch/conf.db \
150 /usr/share/openvswitch/vswitch.ovsschema
152 # Create initial table in config database
153 ovsdb-tool -vANY:console:off transact /etc/openvswitch/conf.db \
154 '[{"op": "insert", "table": "Open_vSwitch", "row": {}}]' \
158 # Create default or update existing /etc/sysconfig/openvswitch.
159 SYSCONFIG=/etc/sysconfig/openvswitch
160 TEMPLATE=/usr/share/openvswitch/scripts/sysconfig.template
161 if [ ! -e $SYSCONFIG ]; then
162 cp $TEMPLATE $SYSCONFIG
164 for var in $(awk -F'[ :]' '/^# [_A-Z0-9]+:/{print $2}' $TEMPLATE)
166 if ! grep $var $SYSCONFIG >/dev/null 2>&1; then
168 sed -n "/$var:/,/$var=/p" $TEMPLATE >> $SYSCONFIG
173 # Deliberately break %postun in broken OVS builds that revert original
174 # XenServer scripts during rpm -U by moving the directory where it thinks
176 if [ -d /usr/lib/openvswitch/xs-original ]; then
177 mkdir -p /usr/lib/openvswitch/xs-saved
178 mv /usr/lib/openvswitch/xs-original/* /usr/lib/openvswitch/xs-saved/ &&
179 rmdir /usr/lib/openvswitch/xs-original
182 # Replace XenServer files by our versions.
183 mkdir -p /usr/lib/openvswitch/xs-saved \
184 || printf "Could not create script backup directory.\n"
186 /opt/xensource/libexec/interface-reconfigure \
187 /opt/xensource/libexec/InterfaceReconfigure.py \
188 /opt/xensource/libexec/InterfaceReconfigureBridge.py \
189 /opt/xensource/libexec/InterfaceReconfigureVswitch.py \
190 /etc/xensource/scripts/vif
194 if [ -f "$f" ] && [ "$t" != "/usr/share/openvswitch/scripts/$s" ]; then
195 mv "$f" /usr/lib/openvswitch/xs-saved/ \
196 || printf "Could not save original XenServer $s script\n"
197 ln -s "/usr/share/openvswitch/scripts/$s" "$f" \
198 || printf "Could not link to Open vSwitch $s script\n"
202 # Clean up dangling symlinks to removed OVS replacement scripts no longer
203 # provided by OVS. Any time a replacement script is removed from OVS,
204 # it should be added here to ensure correct reversion from old versions of
205 # OVS that don't clean up dangling symlinks during the uninstall phase.
208 /usr/sbin/xen-bugtool
210 saved=/usr/lib/openvswitch/xs-saved/$(basename "$orig")
211 [ -e "$saved" ] && mv -f "$saved" "$orig"
214 # Ensure all required services are set to run
215 for s in openvswitch openvswitch-xapi-update; do
216 if chkconfig --list $s >/dev/null 2>&1; then
217 chkconfig --del $s || printf "Could not remove $s init script."
219 chkconfig --add $s || printf "Could not add $s init script."
220 chkconfig $s on || printf "Could not enable $s init script."
223 if [ "$1" = "1" ]; then # $1 = 1 for install
224 # Configure system to use Open vSwitch
225 /opt/xensource/bin/xe-switch-network-backend vswitch
226 else # $1 = 2 for upgrade
228 mode=$(cat /etc/xensource/network.conf)
229 if [ "$mode" != "vswitch" ] && [ "$mode" != "openvswitch" ]; then
230 printf "\nThe server is not configured to run Open vSwitch. To run in\n"
231 printf "vswitch mode, you must run the following command:\n\n"
232 printf "\txe-switch-network-backend vswitch"
234 printf "\nTo use the new Open vSwitch install, you should reboot the\n"
235 printf "server now. Failure to do so may result in incorrect operation."
241 %posttrans %{module_package}
242 # Ensure that modprobe will find our modules.
244 # This has to be in %posttrans instead of %post because older versions
245 # installed modules into a different directory and "rpm -U" runs the
246 # new version's %post before removing the old version's files, so if
247 # we use %post then depmod may find the old versions that are about to
249 depmod %{xen_version}
252 if [ "$1" = "0" ]; then # $1 = 0 for uninstall
253 # Configure system to use bridge
254 /opt/xensource/bin/xe-switch-network-backend bridge
256 # The "openvswitch" service should have been removed from
257 # "xe-switch-network-backend bridge".
258 for s in openvswitch openvswitch-xapi-update; do
259 if chkconfig --list $s >/dev/null 2>&1; then
260 chkconfig --del $s || printf "Could not remove $s init script."
266 # Restore original XenServer scripts if the OVS equivalent no longer exists.
267 # This works both in the upgrade and erase cases.
268 # This lists every file that every version of OVS has ever replaced. Never
269 # remove old files that OVS no longer replaces, or upgrades from old versions
270 # will fail to restore the XS originals, leaving the system in a broken state.
271 # Also be sure to add removed script paths to the %post scriptlet above to
272 # prevent the same problem when upgrading from old versions of OVS that lack
273 # this restore-on-upgrade logic.
275 /etc/xensource/scripts/vif \
277 /usr/sbin/xen-bugtool \
278 /opt/xensource/libexec/interface-reconfigure \
279 /opt/xensource/libexec/InterfaceReconfigure.py \
280 /opt/xensource/libexec/InterfaceReconfigureBridge.py \
281 /opt/xensource/libexec/InterfaceReconfigureVswitch.py
283 # Only revert dangling symlinks.
284 if [ -h "$f" ] && [ ! -e "$f" ]; then
286 if [ ! -f "/usr/lib/openvswitch/xs-saved/$s" ]; then
287 printf "Original XenServer $s script not present in /usr/lib/openvswitch/xs-saved\n" >&2
288 printf "Could not restore original XenServer script.\n" >&2
291 && mv "/usr/lib/openvswitch/xs-saved/$s" "$f") \
292 || printf "Could not restore original XenServer $s script.\n" >&2
297 if [ "$1" = "0" ]; then # $1 = 0 for uninstall
298 rm -f /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyc \
299 /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.pyo
301 rm -f /usr/share/openvswitch/scripts/InterfaceReconfigure.pyc \
302 /usr/share/openvswitch/scripts/InterfaceReconfigure.pyo \
303 /usr/share/openvswitch/scripts/InterfaceReconfigureBridge.pyc \
304 /usr/share/openvswitch/scripts/InterfaceReconfigureBridge.pyo \
305 /usr/share/openvswitch/scripts/InterfaceReconfigureVSwitch.pyc \
306 /usr/share/openvswitch/scripts/InterfaceReconfigureVSwitch.pyo
308 # Remove all configuration files
309 rm -f /etc/openvswitch/conf.db
310 rm -f /etc/sysconfig/openvswitch
311 rm -f /etc/openvswitch/vswitchd.cacert
313 # Remove saved XenServer scripts directory, but only if it's empty
314 rmdir -p /usr/lib/openvswitch/xs-saved 2>/dev/null
320 %defattr(-,root,root)
321 /etc/init.d/openvswitch
322 /etc/init.d/openvswitch-xapi-update
323 /etc/xapi.d/plugins/openvswitch-cfg-update
324 /etc/xensource/bugtool/*
325 /etc/logrotate.d/openvswitch
326 /etc/profile.d/openvswitch.sh
327 /usr/share/openvswitch/python/
328 /usr/share/openvswitch/scripts/ovs-xapi-sync
329 /usr/share/openvswitch/scripts/interface-reconfigure
330 /usr/share/openvswitch/scripts/InterfaceReconfigure.py
331 /usr/share/openvswitch/scripts/InterfaceReconfigureBridge.py
332 /usr/share/openvswitch/scripts/InterfaceReconfigureVswitch.py
333 /usr/share/openvswitch/scripts/vif
334 /usr/share/openvswitch/scripts/sysconfig.template
335 /usr/share/openvswitch/scripts/ovs-bugtool-*
336 /usr/share/openvswitch/scripts/ovs-save
337 /usr/share/openvswitch/scripts/ovs-ctl
338 /usr/share/openvswitch/scripts/ovs-lib.sh
339 /usr/share/openvswitch/vswitch.ovsschema
340 /usr/sbin/ovs-vlan-bug-workaround
341 /usr/sbin/ovs-vswitchd
342 /usr/sbin/ovsdb-server
346 /usr/bin/ovs-parse-leaks
348 /usr/bin/ovs-tcpundump
349 /usr/bin/ovs-vlan-test
351 /usr/bin/ovsdb-client
353 /usr/lib/xsconsole/plugins-base/XSFeatureVSwitch.py
354 /usr/share/man/man1/ovsdb-client.1.gz
355 /usr/share/man/man1/ovsdb-server.1.gz
356 /usr/share/man/man1/ovsdb-tool.1.gz
357 /usr/share/man/man5/ovs-vswitchd.conf.db.5.gz
358 /usr/share/man/man8/ovs-appctl.8.gz
359 /usr/share/man/man8/ovs-ctl.8.gz
360 /usr/share/man/man8/ovs-dpctl.8.gz
361 /usr/share/man/man8/ovs-ofctl.8.gz
362 /usr/share/man/man8/ovs-parse-leaks.8.gz
363 /usr/share/man/man1/ovs-pcap.1.gz
364 /usr/share/man/man1/ovs-tcpundump.1.gz
365 /usr/share/man/man8/ovs-vlan-bug-workaround.8.gz
366 /usr/share/man/man8/ovs-vlan-test.8.gz
367 /usr/share/man/man8/ovs-vsctl.8.gz
368 /usr/share/man/man8/ovs-vswitchd.8.gz
370 %exclude /usr/lib/xsconsole/plugins-base/*.py[co]
371 %exclude /usr/sbin/ovs-brcompatd
372 %exclude /usr/share/man/man8/ovs-brcompatd.8.gz
373 %exclude /usr/share/openvswitch/scripts/*.py[co]
374 %exclude /usr/share/openvswitch/python/*.py[co]
375 %exclude /usr/share/openvswitch/python/ovs/*.py[co]
376 %exclude /usr/share/openvswitch/python/ovs/db/*.py[co]
378 %files %{module_package}
379 /lib/modules/%{xen_version}/extra/openvswitch/openvswitch_mod.ko
380 %exclude /lib/modules/%{xen_version}/extra/openvswitch/brcompat_mod.ko